a beginner’s guide to adobe framemaker

by
Julia Basal, Melissa Mahoney, & Michael Sullivan
a beginner’s guide to adobe framemaker

by
Julia Basal, Melissa Mahoney, & Michael Sullivan
acknowledgements

We would like to thank Professor Janine Solberg for her guidance and editorial input. Special thanks goes to our teaching assistants Garrett Russell and Ismail Eddafali for their excellent tutorials in class and patient assistance in the PWTC computer lab. Finally, we would like to thank our classmates for their support and humor during times of stress.
introduction

For those not involved in the world of technical writing, Adobe FrameMaker may sound like a photo-editing or framing-design application. It's a program that you probably hadn't heard of until your first technical writing class or perhaps even until the first job that you applied for. But you may have gathered that for many tech writing jobs, FrameMaker is a staple for recommended knowledge. So why is a relatively unknown program like FrameMaker such a big deal anyway?

**FrameMaker is the industry standard for building long documents in the world of tech writing.** Want to write a 1000-page manual on a user interface? No problem. FrameMaker handles large and intricate documents in a simple editing interface called Unstructured Authoring much better than home word processors like Microsoft Word.

Are you drafting instructions for a website that has separate procedures for Free Membership versus Premium Membership? Simply write one document for both, tagging the text specific to each version of the software with a function called conditional text. FrameMaker allows you to single-source your content, meaning that you can create multiple final outputs from a single source text.

Need content that can be incorporated into your company's DITA scheme or Content Management System? Done. FrameMaker has a Structured Authoring mode that allows you to create documentation in XML format. For these reasons and more, knowledge of FrameMaker has become one the most sought-after skills for any starting technical writer.

However, FrameMaker does have a bit of a learning curve. While FrameMaker may share some common characteristics with other Adobe programs like Photoshop, InDesign, and Illustrator, in others it is a whole new animal. That's why we created *A Beginner's Guide to FrameMaker* to bring you through the basics of creating your first document and to lead you in the direction of its more advanced features.

**Within these pages you’ll learn how to:**

- Create new blank documents, documents from templates, and master pages in the Unstructured Authoring mode
- Modify text through paragraph and character tags
- Insert graphics and tables and how to manipulate them within a document
- Compile several files into one book with an automatically generated table of contents and index
- Produce your document in print or online

While this manual doesn’t include information on advanced features like tagging conditional text or working in the Structured Authoring mode, the basic skills covered here will allow you to create functional, professional, and efficient documentation in no time.
## Table of Contents

Acknowledgements ........................................................................................................ iii
Introduction ....................................................................................................................... iv
Table of Contents ............................................................................................................ v

### Chapter 1: Getting Started .......................................................................................... 1

1.1 Creating a new document ......................................................................................... 2
1.2 Using and modifying an existing template ................................................................. 3
1.3 Creating headers, footers, and page numbers ............................................................ 4
1.4 Creating and editing master pages ............................................................................ 5
1.5 Applying character and paragraph tags ...................................................................... 6
1.6 Saving a work ............................................................................................................. 8

### Chapter 2: Working with Graphics ............................................................................. 9

2.1 Inserting a table and applying a new table tag ......................................................... 10
2.2 Importing a graphic ................................................................................................. 12
2.3 Adding a text frame into a master page ..................................................................... 14
2.4 Wrapping text around a graphic .............................................................................. 15
2.5 Inserting an anchored frame ..................................................................................... 16

### Chapter 3: Organizing Content Using Books ............................................................. 19

3.1 Creating a book ........................................................................................................ 20
3.2 Adding page numbers to a book .............................................................................. 21
3.3 Saving a book .......................................................................................................... 22
3.4 Creating a table of contents .................................................................................... 23
3.5 Formatting a table of contents ................................................................................ 24
3.6 Adding tab leaders to your table of contents ........................................................... 26
3.7 Preparing your document with index markers ......................................................... 28
3.8 Creating your index ................................................................................................ 29
3.9 Formatting and titling your index ............................................................................ 30

### Chapter 4: Publishing Your Work .............................................................................. 33

4.1 Printing your document ........................................................................................... 34
4.2 Creating a PDF document ....................................................................................... 35
4.3 Creating HTML ......................................................................................................... 36

Index ............................................................................................................................... I
This page has been intentionally left blank.
chapter 1: getting started
1.1 creating a new document

FrameMaker is often used to publish lengthy materials, but the work is generally not authored in one unified piece. Instead, FrameMaker uses a system in which many Documents are created and then combined into a Book. Creating a Document is simple and is similar to creating new documents in other Adobe programs.

creating a new document

1. Boot Adobe FrameMaker. A pod appears which contains the following options:
   - The option to reopen Recent Items
   - The option to Create New items
   - The option to create new documents using pre-made Templates
   - The option to view various Resources and Adobe pages
3. From the top of the dialog box, select either Portrait, Landscape, or Custom layout. If you select either Portrait or Landscape, a new document opens with the orientation you have selected. If you select Custom, the Custom Blank Paper dialog box appears with the following options:
   - **Page Size:**
     Select a standard size for the pages with the drop-down menu or enter your own values in Width and Height.
   - **Columns:**
     Enter the number of columns you want to appear across the page in the Number field, and provide a distance for the columns to be spaced apart in the Gap field.
   - **Column Margins:**
     Enter the distance from the edge of the page of all four sides using the Top, Bottom, Left, and Right fields.
   - **Pagination:**
     Use the Single-Sided or Double-Sided options to choose how the book will be printed. Use the drop-down menu to select which side the first page is printed upon.
   - **Units:**
     Use the drop-down menu to change the units that the options appear in.
4. Format the custom page layout as you desire.
5. Click Create. A new document opens with the custom layout.

note: European A3, A4, A5, and B5 options will still show up as a default with inches selected.
### 1.2 Using and Modifying an Existing Template

FrameMaker comes with several templates for letters, memos, reports, newsletters, outlines, and books that you can use to get started on a document that you need to complete quickly. Using templates allows you to focus on the content instead of the layout. However, you can also modify templates to your own specifications and then save them as new templates in your personal template folder.

#### Using a Template

To use a template:

1. From the menu bar, select **File > New > Document**. The **New** dialog box appears.
2. From the lower left corner of the dialog box, click **Explore Standard Templates**. The **Standard Templates** dialog box appears.
3. From the left-side of the dialog box, click through the template options to see a small preview of each. When you find a template you like, do one of the following:
   - Click **Create**: This will create a blank document with the template layout and some placeholder text.
   - Click **Show Sample**: This will open a sample document with filler text to show you what a full template might look like. You can work inside this document and make changes to it, however, it might be more time consuming as you will have to replace all of the filler text with your own.
4. Click into the body area of the document and begin entering your text.

   **Note**: To create a personalized template, access the Master Pages by clicking **View > Master Pages**. Adjust the template then click **File > Save As** and save the template in the desired directory. Save the template with a new name so that you don’t overwrite the original.
1.3 creating headers, footers, and page numbers

Headers, footers, and page numbers can all be edited within the master pages that you create in 1.4 Creating and Editing Master Pages. Header and footer elements already exist within master pages that you create. For the purposes of this tutorial, we will create a footer with an author name and page numbers, and a header with chapter titles.

to create a footer with text

1. From the menu bar, click View > Master Pages.
2. Click within the body of your A master page.

   **note:** You can tell you’re in master page A because the left-hand side of the bar at the bottom of the page will read Flow: A.

3. From the bottom of the page, click within the Footer element.

   **note:** You can tell that you are in the footer element because the left-hand side of the bar at the bottom of the page will read Footer.

4. Type the author’s name in the footer.
5. Press the Tab key once to center the text, or twice to right-justify the text.
6. From the menu bar, click File > Save. Your footer is saved. The footer appears on every page that the master page is applied to.

adding page numbers to your footer

1. From the menu bar, select Special > Variables. The Variables pod appears at the bottom of the window.
2. From the top of the list in the Variables pod, double-click Current Page #. A pound key (#) appears in your footer. This pound key will automatically generate the correct page number of any page that this master page is applied to.
3. Press the Tab key once to center your page numbers, or twice to right-justify your page numbers.
4. From the menu bar, click File > Save. Your footer is saved with page numbers.
1.4 creating and editing master pages

Master pages are used in order to create a consistent format for all of your pages. The elements that you use for master pages are usually considered background elements, meaning they are not made to be edited and changed. Master pages are important for setting up things like logos, headers, footers, and design elements.

changing your master pages

Framemaker allows you to view your master pages specifically, away from the regular body pages. You can create design elements using the various line and shape tools FrameMaker offers, or you can import graphics. To view your master pages use: View > Master Pages.

There are two separate types of text boxes that can be created for a document:

- **Template Text Frames:** Template frames are frames that are designated with a Flow title. These are the basic frames that you would type in on your body pages. Template text boxes can have their size changed and be broken up into multiple columns, but are generally kept as the dominant element on the page. These will already be present in a blank document but can be altered and applied using master pages.

- **Background Text Frames:** Background text frames are untagged flow boxes that will be consistent throughout the pages that they are applied to. These frames would be filled while in the master page and not while viewing body pages. Background text frames with untitled flows are good for things like headers and footers where the text would be consistent on all the pages the master would be applied to.

making new master pages

You can make new master pages based on existing ones in order to keep your pages consistent while still having separate master pages for those with slightly different layouts.

1. Select View > Master Pages.
2. Special > Add Master Page.
3. Select the page to base the new master on from Copy From Master Page.
4. Select Add.

changing master pages

If you need to apply a different master page from the one that is currently assigned to a body page, you can do so quickly and easily.

1. Select View > Master Pages.
3. Select your desired master page from the Use Master Page field.
4. Select which pages need the master page using either Current, Odd, Even, or entering a page range.
5. Select Apply.
1.5 applying character and paragraph tags

You can use tags (what you may be used to as “styles” in programs like Adobe InDesign or Microsoft Word) to quickly and efficiently control formatting of characters, entire paragraphs, and even tables. Using tags allows you to quickly format sections of text and re-use exact formatting to maintain consistency in long documents.

applying character tags

Applying a character tag will change only the characters you select, not the entire surrounding paragraph.

To apply a character tag:

1. Select the text you want to format.
2. If the Character Designer is not available as a panel at the side of your workspace, in the menu bar, click Format > Characters > Designer.
3. In the Character Tag field, type or select a character tag from the drop-down menu.
4. To create a new character tag, click the arrow next to Commands in the lower left corner and select New Format. The New Format window appears.
5. Type the name of the new tag and click Create.
6. In the Character Designer, adjust the available fields so that the character tag looks the way you want it to.
7. To apply the character tag, click Apply.
8. To apply any adjustment made to an existing character tag, click Update All.
9. To return an adjusted character tag to its original settings, click Reset.

applying paragraph tags

Paragraph tags will change the formatting of the entire paragraph surrounding the text you have selected.
To apply a paragraph tag:

1. Select the text or insert your cursor in the paragraph you want to format.
2. If the Paragraph Designer is not available as a panel at the side of your workspace, in the menu bar, click Format > Paragraph > Designer. The designer appears with the Basic tab open.
3. In the Paragraph Tag field, type or select a paragraph tag from the drop-down menu.
4. To create a new paragraph tag, click the arrow next to Commands in the lower left corner and select New Format. The New Format window appears.
5. Type the name of the new tag and click Create.
6. In the Paragraph Designer, adjust the available fields so that the paragraph tag looks the way you want it to using the following tabs:
   - Basic: Allows you to adjust indentation, alignment, line spacing, tab stops, and the subsequent paragraph tag when you press Enter.
   - Default Font: Allows you to adjust font family, size, angle, weight, variations, color, spread, stretch, language, underline, overline, strikethrough, change bar, superscript, subscript, small caps, lowercase, uppercase, pair kern, tsume, and background color.
   - Pagination: Allows you to adjust where the paragraph starts on the page, how it will wrap to subsequent pages, heading placement, text flow across columns, and format inheritance.
   - Numbering: Allows you to adjust automatic numbering, building blocks, formatting for numbering, and position of numbering.
   - Advanced: Allows you to adjust hyphenation, word spacing and justification, and lines above or below paragraphs.
   - Asian: Allows you to adjust spacing when using Asian fonts.
   - Table Cell: Allows you to adjust font placement within a table cell.
7. To apply the paragraph tag, click Apply.
8. To apply any adjustment made to an existing paragraph tag, click Update All.
9. To return an adjusted paragraph tag to its original settings, click Reset.
1.6 saving a work

Documents created in Adobe FrameMaker can be saved in a number of formats. A FrameMaker document is saved as .FM but there are many other formats your document can be saved as, including .PDF, .HTML, and .XML. This module focuses on saving as a .FM file, but you can read about saving in other formats in Chapter 4.

saving a document

1. From the menu bar, click File > Save. If this is the first time you are saving the document, the Save Document dialog box appears.
2. In the File name field, enter the name you want to give your document.
3. Using the drop-down menu in the Save in field, navigate to the location you want to save your document in.
4. Click Save. Your document is saved. Now, every time you click File > Save, your document will save under the name and location you have selected.

saving a document under a different name or location

1. From the menu bar, click File > Save As.
2. In the File name field, enter the new name you want to give your document.
3. Using the drop-down menu in the Save in field, navigate to the new location you want to save your document in.
4. Click Save. Your document is saved with a new name and/or location.

note: Saving a document these ways will keep them in the .FM format unless you select otherwise.

note: FrameMaker will alert you to a Document that isn’t saved after changes are made by placing an Asterisk (*) in the Page Status, in the toolbar at the top.
chapter 2: working with graphics
2.1 inserting a table and applying a new table tag

FrameMaker allows you to insert and format tables within your documents, so that there is no need to import a table you created in a different program. Additionally, you can use a table tag to apply consistent formatting to all the tables in your document.

inserting a table

To insert a table into your document:

1. From the menu bar, select Table > Insert Table. The Insert Table dialog box appears.

![Insert Table dialog box]

2. From the options under the Table Format field, select the format that most closely resembles the desired look of your table. The default options are Format A and Format B.

3. Adjust Columns, Body Rows, Heading Rows, and Footing Rows to your desired specifications.

   note: Heading rows refer to the topmost rows of your table, which list the title of each column. Footing rows refer to the bottom-most rows of your table, which consist of text that repeats at the bottom of tables which are multiple pages in length.

4. Click Insert. The table is inserted into your document.

applying a new table tag

To apply a new table tag:

1. From the menu bar, select Table > Format > Table Designer. The Table Designer appears as a panel on the side of your workspace.

2. Type a new name into the Table Tag field.

3. Click Apply. The New Format dialog box appears with the new name in the Tag field.
4. Click **Create**. The new name appears in the Table Tag field of the Table Designer.

Notice that when the new table tag appears in the New Format dialogue box, you have the option to store the tag in the catalog. Make sure **Store in Catalog** checked if you want to save this table tag.

5. In the Table Designer, adjust the available fields using the following tabs:
   - **Basic**: Allows you to adjust indentation, spacing, alignment, and how the table will break across pages.
   - **Ruling**: Allows you to adjust the borders around columns, rows, and the entire table.
   - **Shading**: Allows you to adjust the colors and shading of headings, footings, and the body.

6. Click **Update All** on each tab to save changes. The new table tag is applied.
2.2 importing a graphic

When importing a graphic into a FrameMaker document, there are a few more steps to follow and things to note than when importing a graphic into some other software.

To import a graphic:

1. Position your cursor where in your document you want to import the graphic.
2. From the menu bar, select **File > Import > File**. The **Import** dialog box appears.
3. Select the graphic you wish to import from the location it is saved to.
4. At the bottom of the dialog box select either **Import by Reference** or **Copy Into Document**.

**note:** Importing the graphic by reference means that instead of making the graphic a part of your document, you are actually just copying the graphic’s link into your document. This is beneficial because your file size will be smaller, however, if the link is ever broken your graphic will be lost. Importing a graphic by copying means that the graphic becomes part of your document and thus doesn’t rely on a link. This is beneficial because, if the link is ever broken, the graphic will still appear in your document. The downside is that copying a graphic increases the file size of your document.
5. Click **Import**. If FrameMaker can tell which type of graphic you are importing, the **Imported Graphic Scaling** dialog box appears. If not, the **Unknown File Type** dialog box appears, and you must manually select the type of graphic from the list provided, then click **Convert**.

6. Select your desired sizing option from the dialog box.

   **note**: The different options in the dialog box allow you to change the size, or DPI (dots per inch), of your graphic. If a value appears next to the **Custom dpi** option, that value represents the actual dpi of the graphic. The **Fit in Selected Rectangle** option resizes the graphic so that it fits within a selected anchored frame, but this option may distort the graphic.

7. Click **Set**. The graphic is imported into your document.
Adding a text frame into a master page allows you to change the layout of your document to, for instance, a two-column layout easily. Additionally, whatever text you type into text frames that are in your master pages won’t show up in body pages, allowing you to type notes into the text frames in your master pages.

To add a text frame into your master page:

1. From the menu bar, select View > Master Pages.
2. Hold down the Ctrl key and click anywhere within the main text frame to select it.
3. Using the black handles that surround the text frame, adjust the size of the text frame so that there is room to add an additional text frame.
4. If the tools panel is not already open to the left of your document, from the menu bar select Graphics > Tools. The tools panel opens.
5. From the tools panel, select the Place a Text Frame tool.
6. Click and drag your cursor until your text frame is the desired size, then release your cursor. The Add New Text Frame dialog box appears.

   **note:** You can adjust the size of your text frame after it is created by using the Select Object tool from the tools panel.

7. Under Text Frame Type, select Template for Body Page Text Frame.

8. Click Add. A message appears telling you that the new frame is connected to the end of the original text frame.

   **note:** Text from the original text frame will automatically flow to the text frame you just created once the original text frame is filled with text. Even if you place the new text frame to the left of the original, your text will start in the original frame at the right and flow to the new frame at the left.

9. Click OK. A text frame is inserted into your master page.
2.4 wrapping text around a graphic

If your document includes both text and graphics, one of the most useful things to know when learning about graphics is how to wrap your text around them.

To wrap text around a graphic:

1. Select the graphic you wish to wrap text around.
2. From the menu bar, select Graphics > Runaround Properties. The Runaround Properties panel appears.

![Runaround Properties panel]

Gap refers to the amount of space between the text and the graphic. The default is 6.0 pt.

3. Select your desired text wrapping option:
   - Run Around Contour: Text wraps around the edges of the graphic.
   - Run Around Bounding Box: Text wraps around an invisible square surrounding the image.
   - Don’t Run Around: Text runs through the image.
   - As Is: Text remains as is, without wrapping.
4. In the Gap field, type how much space you would like between the image and the text.
5. Click Set. The text wraps around the graphic.
2.5 inserting an anchored frame

Anchored frames are used to place graphics into your documents, and can also be used to crop and mask them. Anchored frames are automatically created around all imported images, but you also have the ability to create an anchored frame before inserting your graphic so that you can size and position it accordingly.

To insert an anchored frame:

1. Click the location in your document where you want the anchored frame to be created.
2. From the menu bar, select Special > Anchored Frame. The Anchored Frame panel appears.

3. From the drop-down menu next to Anchoring Position, adjust the position of the anchored frame:
   - **Below Current Line**: Creates the anchored frame below the line your cursor is on.
   - **At Top of Column**: Creates the anchored frame at the top of the column your cursor is in.
   - **At Bottom of Column**: Creates the anchored frame at the bottom of the column your cursor is in.
   - **At Insertion Point**: Creates the anchored frame on the line your cursor is on.
   - **Outside Column**: Creates the anchored frame outside of the column, in the side head area.
   - **Outside Text Frame**: Creates the anchored frame in the margin of the document.
   - **Run into Paragraph**: Creates the anchored frame in the line your cursor is on, with text displayed on one side of the anchored frame.

When you select the options Below Current Line, At Top of Column, or At Bottom of Column, you can make your anchored frame cropped or floating. Cropped means that any portion of the image that lies outside of the frame will be cropped. Floating means that the frame will move to the next column if there is not enough room left in the column at the insertion point.
4. From the drop-down menu next to **Alignment**, adjust the alignment of the anchored frame.
5. In the spaces provided under the **Size** area, adjust the width and height of the anchored frame.
6. Click **New Frame**. An anchored frame is created inside your document.

When you select the options **At Insertion Point**, **Outside Column**, or **Outside Text Frame**, you have the added option to choose a distance from baseline, which is the distance between the frame and the bottom of the line of text. Additionally, the **Outside Column** and **Outside Text Frame** options allow you to choose the distance the frame will be from the text column.
This page has been intentionally left blank.
chapter 3:
organizing content using books
3.1 creating a book

A book is a special FrameMaker file that groups individual documents into one file. You can then work with these documents either as a whole or separately, including adding numbering, updating cross-references, and generating indexes.

To build a book:

1. Open the file that you want to add to a book.
2. In the menu bar, File > New > Book. The new book panel appears on the left and a pop-up window appears asking if you want to add the current file to the new book.
4. In the menu bar, click File > Save Book or click the floppy disk save icon in the new book panel. You can name the book file as part of the saving process.

adding files to a book

To add a file to a book after you have created a book file, do one of the following:

2. In the menu bar, click Add > Files. The Add Files to a Book dialog box appears.
3. Select the file you want to add and click Add.

or

1. In the top left corner of the new book panel, click the Add File button. The Add Files to a Book dialog box appears.
2. Select the file you want to add and click Add.
3.2 adding page numbers to a book

You can use FrameMaker’s page numbering options to customize the page numbers in your book or long document. For example, you can use roman numerals for front and end matter and arabic numerals for body pages.

To add page numbers to a completed document:

1. Open the book file that you want to add page numbers to.
2. Open all of the files within the book file.
4. Click the Page tab.
5. Select the radio button for Continue Number from Previous Page in Book.
6. Click Set.
7. In the book panel, select the file that will begin with the number one in the numbering scheme.
9. Click the Page tab.
10. Click the radio button for First Page # and type 1 in the field.
11. In the Format drop-down menu, select Numeric.
12. Click Set.

note: If you add new files to the book after setting the numbering scheme, you may have to repeat steps 1-6 with the new file selected in the book panel.
3.3 saving a book

Saving a book works the same way as saving a document. Once you have your book created (see module 3.1), click within the Book pod and complete the following steps.

saving a book

1. From the menu bar, click File > Save Book. If this is the first time you are saving the book, the Save Book dialog box appears.
2. In the File name field, enter the name you want to give your book.
3. Using the drop-down menu in the Save in field, navigate to the location you want to save your book in.
4. Click Save. Your book is saved. Now, every time you click File > Save Book, your book will save under the name and location you have selected.

saving a book under a different name or location

1. From the menu bar, click File > Save Book As.
2. In the File name field, enter the new name you want to give your book.
3. Using the drop-down menu in the Save in field, navigate to the new location you want to save your document in.
4. Click Save. Your book is saved with a new name and/or location.

note: Saving a book these ways will keep them in the .book format unless you select otherwise.
3.4 creating a table of contents

Tables of contents are an essential part of any long document or book, as they facilitate navigability and thus usability. You can use the Table of Contents function in FrameMaker to automatically generate a table of contents that you can update any time you add or delete material.

To prepare your document for a table of contents, mark your document consistently with paragraph tags in the manner that you want them to appear in your table of contents (see 1.5 Applying Paragraph and Character Tags). For example, text marked with the Heading 1 tag will appear as a first-level item in the table of contents.

**note:** Because the table of contents pulls text from the Heading 1 tag, make sure that your headings only contain the text that you want to appear in the table of contents.

To generate a table of contents:

1. Open the book file that you want to add a table of contents to and all of the files it contains.
2. In the book panel, select the file that you want the generated table of contents file to appear next to.
3. In the menu bar, click **Add > Table of Contents**. The **Set Up Table of Contents** dialog box appears.
4. In the **Add File** drop-down menu, choose whether the table of contents will appear before or after the file you selected.
5. In the **Don’t Include** field, select the paragraph tags that you want the table of contents to generate from by clicking the left-pointing arrow. The selected tags now appear in the Include Paragraphs Tagged field.
6. Leave **Create Hypertext Links** checked off if you want to be able to click on the table of contents and jump to the corresponding page.
7. Click **Add**. The **Update Book** dialog box appears.
8. If it isn’t already, check off **Generate Table of Contents, Lists, and Indexes**.
9. Click **Update**. The generated table of contents file appears above or below the file that you selected in the book panel.
10. In the book panel, double click the table of contents file to open it, and then click **File > Save**.
3.5 formatting a table of contents

The table of contents that FrameMaker generates for you is not always the most well organized or beautiful document. Luckily, you can easily format your table of contents to reflect the rest of your manual’s style and to greatly improve visual hierarchy.

To format a table of contents:

1. Open the table of contents file that you want to format.
2. Click into the first line of your table of contents.
   
   **note**: Notice that a TOC-specific paragraph tag will have been generated for the text, such as ChapterTitleToC or Heading1TOC.

3. In the menu bar, click **Format > Paragraphs > Designer** to open the Paragraph Designer. The Paragraph Designer opens with the Basic tab displayed.
4. In the **Indents and Spacing** group, click the arrow under the **Above Pgf** field and select the spacing you want to appear after the tag from the drop-down menu. For example, select 2 Lines.
5. Click **Update All**. If a pop-up window appears saying that some of the paragraphs have overrides, click **Remove Overrides**.
6. In the **Default Font** tab, click the arrow next to the **Weight** field and select **Bold** from the drop-down menu, or adjust the font in the manner you want. Click **Update All**.
7. Click into the next line of text in your TOC that has a different heading. For example, if you were clicked into ChapterTOC, click into Heading1TOC.
8. In the **Basic** tab, click the arrow under the **Above Pgf** field and select the spacing you want to appear after the tag from the drop-down menu. For example, select 1 Line.
9. In **Left** field, type in the amount of indentation you want before the selected tag. For example, type 0.3.
10. Click **Update All**. If a pop-up window appears saying that some of the paragraphs have overrides, click **Remove Overrides**.
11. Repeat steps 10-13 to adjust any other tags that appear in your TOC, such as Heading2TOC.
12. Save the document.

When you click into a line in the table of contents, the tag name will appear in the Paragraph Tag field.
adding automatic chapter numbers

To automatically add chapter numbers to a TOC paragraph tag:

1. Click into line of text labeled with the ChapterTOC tag and open the Numbering tab in the Paragraph Designer.
2. Check off Autonumber Format and type the following in the field below: **Chapter <n+>**.
3. Click Update All. The words **Chapter 1** will appear in front of the text on the line that you are clicked into.

Type **Chapter <n+>** in the AutoNumber Format field to automatically number your Chapter headings in the table of contents.
3.6 adding tab leaders to your table of contents

Although you may have improved the visual hierarchy of your table of contents in 3.5 Formatting a Table of Contents, the document still doesn’t look quite like it should. This module will show you how to move your page numbers to the right of the page with a dotted line, or tab leader, extending from the tag names on the left to the numbers on the right.

To add tab leaders to your table of contents:

1. Open the table of contents file that you want to format.
2. From the menu bar, click **Format > Paragraphs > Designer** to open the Paragraph Designer.
3. Click into the first line of your table of contents directly after the words but not the number. The tagged text will be to the left of your cursor, and a space and the page number will be to the right.
4. In the **Basic** tab of the Paragraph Designer, click the **Edit...** button beneath the **Tab Stops** field. The **Edit Tab Stop** dialog box appears.
5. In the **New Position** field, type **4.5**.
6. In the **Alignment** area, select the **Right** radio button.
7. In the **Leader** area, select the desired leader style.
8. Click **Continue**.
9. In the Paragraph Designer, click **Update All**.

**note:** It will seem as if nothing has happened; this is normal, and you will be able to change that in the next few steps.

10. Repeat steps 3-9 for any other tags in your table of contents, such as Heading2TOC.

**adjusting reference pages**

In order to have your tab leaders show up in the table of contents, you will need to adjust the table of contents Reference Pages. By adjusting these pages, you will not only see the desired tab leader, you will also be able to maintain consistent formatting throughout your table of contents if you need to add more content later.

1. Open the table of contents file that you want to format.
2. In the menu bar, click **View** > **Reference Pages**.
3. Scroll to the very last Reference Page and click into it.

   **note**: Make sure that Flow: TOC appears in the lower left corner of the status bar.

4. Locate the line that reads `<$paratext> <$paranum>`.

   **note**: There may be more than one line with this text. Simply start with the first.

   Click between `<$paratext>` and `<$paranum>` and delete the space there.

5. Press **TAB**. A dotted line in the style of your tab leader will appear between `<$paratext>` and `<$paranum>`. If a dotted line does not appear, don’t worry. It should appear when you regenerate the table of contents.

6. In the menu bar, click **View** > **Body Pages**.
8. In the menu bar, click **Edit** > **Update Book**. The **Update Book** dialog box opens.
9. Click **Update**. Your table of contents will regenerate with tab leaders.
3.7 preparing your document with index markers

FrameMaker makes the process of creating an index simple. You can create an index for multiple documents combined into a book or for a single document, called a stand-alone index. Either way, you must mark the words you want to include in your index manually. This module shows how to mark documents you want to include in your index.

To prepare your document with index markers:

1. Open the document you want to create an index for.
2. Highlight the first word you want to appear in your index.
3. From the menu bar, select Special > Marker. The Marker panel appears with the highlighted word in the space under Marker Text.
4. From the drop-down menu next to Marker Type, select Index.
5. Click New Marker.
6. Continue highlighting words you wish to incorporate into your index, and selecting New Marker in the Marker panel to add them to your index.

**note:** If the Marker panel closes after each new entry you make to the index, you can keep it open by clicking the Marker tab, holding the left-mouse button, and dragging the tab until you have moved the Marker panel from the pod to a location where it is not connected to other open panels.

7. When you have finished adding words to your index, close the Marker panel.
8. Save your document.
3.8 creating your index

After you’ve marked the words you wish to appear in your index (see 3.7 Preparing Your Document with Index Markers), you can create your index by following the steps below. This index will incorporate all the entries you have marked.

To create your index:

1. Open the document in which you have marked index entries.
2. From the menu bar, select Special > Standard Index. A message appears asking if you wish to create a stand-alone index.
3. Click Yes. The Set Up Standard Index dialog box appears.

   **note:** A stand-alone index is an index for a single document.

4. In the Suffix field, adjust how you want your index to be labeled. The default is IX.
5. In the drop-down menu next to Add File, select whether you want your index to appear before or after the document you are currently indexing.

   **note:** Because you are creating a stand-alone index, After is the only choice available, however, if you were adding the index to a new book, Before would be an available option also.

6. Make sure Index is the only marker that appears in the space under Include Markers of Type. If Index does not appear, add it by selecting it from the list under Don’t Include.
7. Click Set. Your index is created in a separate file.
3.9 formatting and titling your index

Once you’ve marked the words you wish to appear in your index and created your index (see modules 3.7 Preparing Your Document With Index Markers and 3.8 Creating Your Index), you will probably want to format it and give it a title.

formatting your index

To format your index:

1. Open your index file.
2. Open the Paragraph Designer panel.
3. Place your cursor within the line of the first index entry, under the single letter which is the title of the first group of index entries.
4. Click the Basic tab in the Paragraph Designer.
5. From the drop-down menu under Above Pgf, select 1 Line.

Selecting 1 Line (14.0 pt) from the drop-down menu under Above Pgf puts one line space between the title of your first index group and the first index entry.

6. Click Apply.
7. From the Paragraph Designer, click the Default Font tab.
8. From within this tab, adjust the font and font-styles as you desire.
9. Click Apply. Your index is formatted.
titling your index

To title your index:

1. Place your cursor before the first letter in your index.
2. Press the **Enter** key.
3. In the blank line above the first letter in your index, type *Index*, or the desired index title.
4. From the **Default Font** tab of the Paragraph Designer, select the paragraph tag you wish the title of your index to be labeled as.

5. Click **Apply**.
6. From the different tabs within the Paragraph Designer, format your index title as you desire.
7. Click **Update All**. Your title is created and formatted.
This page has been intentionally left blank.
chapter 4: publishing your work
4.1 printing your document

Printing documents in FrameMaker is a lot like printing in other forms of word processing software, but it includes some options that can alter the way your document prints. FrameMaker allows you to choose whether or not to show things such as crop marks, registration marks, and graphics when you print. If you were using Structured FrameMaker, you could also choose to show or hide tag boundaries.

printing your document
1. Select **File > Print** to make the **Print Document** dialog box appears.
2. Use the radio buttons under **Print Page Range**, select whether you would like to print **All pages**, or a specific range using the **Start Page** and **End Page** fields

adjusting other options
- Selecting either **Odd-Numbered** or **Even-Numbered Pages** can keep the number of pages used lower
- Selecting **Low-Resolution Images** can reduce the amount of ink that is used
- Selecting from the **Registration Marks** drop-down allows you to include any marks the document has
- Changing the amount of **Copies** allows you to print multiple versions of the document
- From the bottom of the dialog box, click **Print**. Your document is printed.

double-sided printing
1. Select **File > Print**. The **Print Document** dialog box appears.
2. In the dialog box, check only **Odd-Numbered Pages**, leaving Even-Numbered Pages unchecked.
3. Click **Print**.
4. Place the printed document upside down on the paper tray of your printer.
5. From the menu bar, select **File > Print**.
6. In the Print Document dialog box, check only **Even-Numbered Pages**, leaving Odd-Numbered Pages unchecked.
7. Click **Print**. Your document is printed double-sided.

**note:** Depending on how your printer works, you may need to check **Last Sheet First** from the Print Document dialog box in order to ensure that the document does not print the final pages on the other side of beginning pages, and vice versa.
4.2 creating a PDF document

Publishing work in the PDF format has many benefits. One is cross-compatibility. PDFs can be viewed in Adobe Acrobat, Adobe Acrobat Reader, and any viewing software that supports the file type. Another benefit is that PDF files utilize bookmarks and linking so that chapters in the table of contents, cross-references, and hyperlinks can simply be clicked, and the reader is brought directly to them in the document.

creating a PDF

1. Select File > Save As PDF. The Save Document dialog box appears, with PDF selected in the Save as type field.
2. Click Save. The PDF Setup dialog box appears.
3. Adjust the settings in this dialog box as you desire.
4. From the bottom of the dialog box, click Set. Your document is saved as a PDF.

creating PDF with bookmarks

1. Select File > Save As PDF. The Save Document dialog box appears, with PDF selected in the Save as type field.
2. Click Save. The PDF Setup dialog box appears.
3. From the top of the dialog box, select the Bookmarks tab.
4. Ensure the box next to Generate PDF Bookmarks is checked.
5. Ensure that the paragraph styles you want to function as Bookmarks are present in the Include Paragraphs field. To add a paragraph style which is not in the Include Paragraphs field, select it from the list in the Don’t Include field, and click the left-facing arrow button. To remove a paragraph style from the Include Paragraphs field, select it and click the right-facing arrow button.
6. From the bottom of the dialog box, click Set. Your document is saved as a PDF with bookmarks, which provides your PDF document the ability to link to different parts of the text based on what style it was written in.

Note: If you are using structured FrameMaker, you can also change the use of XML Tags within the document.
4.3 creating HTML

FrameMaker can be used to publish your work in HTML, which gives readers the ability to access links and easily jump to chapters and sections. FrameMaker also gives you the ability to publish your FrameMaker files with Adobe RoboHelp. Generating HTML with FrameMaker can yield working HTML for the documents, but it is important to remember that the definitions of formats in FrameMaker are unlimited, while in HTML there must be specific elements used. With these issues in mind, you will likely need to put more consideration into how you’re designing your work if you plan on generating HTML based on the document.

HTML-exporting issues

- Scaling or cropping of .GIF images will not carry through to the HTML
- Graphics and text that are located within anchored frames are converted to .BMP

Utilizing the pre-made templates that are provided through FrameMaker can lessen the amount of fine-tuning that has to happen after the files are published.

While FrameMaker will work to generate HTML and the content may look similar to how it looked within the program, using Cascading Style Sheets (CSS) can be helpful for a more visually appealing product in the end:

1. Select File > Save your FrameMaker documents as an .html. The program will automatically create a .CSS file to accompany it.
2. Use that .CSS file to add more style rules to the document.
3. When hosting your .html file created by FrameMaker, ensure that the .css file appears in the same folder when it is hosted.

You can use FrameMaker to include hyperlinks in the HTML it generates in order to link the reader from one page to the next:

1. Highlight the desired text.
2. From the menu bar, select Special > Hypertext.
3. From the drop-down menu next to Command, select Message Client.
4. Type message URL <desired url> in the Syntax field.
5. Click New Hypertext Marker.
6. Repeat this process until you have created hyperlinks for all desired text.
index

A
adding a text frame 14
adding automatic chapter numbers 25
adding page numbers to a book 21
adding page numbers to your footer 4
adding tab leaders 26
anchored frame 16
applying a new table tag 10

B
background text frames 5
book 20, 22
bookmarks 35

C
character designer 6
character tags 6
column margins 2
columns 2
create a footer 4
creating a new document 2
creating a PDF 35
creating headers 4

double-sided printing 34

F
formatting a table of contents 24
formatting your index 30

H
HTML 36

I
importing a graphic 12
index 29
index markers 28
inserting a table 10

M
master pages 5, 14

P
page size 2
pagination 2
paragraph designer 7
paragraph tags 6
printing 34

R
reference pages 26
runaround properties 15

S
saving 8
standard templates 3

T
table designer 10
table of contents 23
template text frames 5
titling your index 31

U
units 2
using a template 3

V
variables 4

W
wrapping text 15